summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2013-11-23 18:30:48 +0800
committerYu-Jie Lin <livibetter@gmail.com>2013-11-23 18:30:48 +0800
commitdd0b152c0d664eb33b9e25748eab50d2e2a7a45a (patch)
tree888fe82c7cc555358eb15c9b167d060fa8ad3f30 /tests
parent3a91ce8dfee161eaeb38d637305c0ef54ebdafdf (diff)
downloadsmartypants-dd0b152c0d664eb33b9e25748eab50d2e2a7a45a.tar.gz
add isort test
Diffstat (limited to 'tests')
-rw-r--r--tests/test.py3
-rw-r--r--tests/test_cli.py4
-rw-r--r--tests/test_deprecated.py4
-rw-r--r--tests/test_setup.py3
4 files changed, 9 insertions, 5 deletions
diff --git a/tests/test.py b/tests/test.py
index 6b2c5da..c9451ac 100644
--- a/tests/test.py
+++ b/tests/test.py
@@ -6,7 +6,8 @@ import doctest
import unittest
import smartypants
-from smartypants import Attr, smartypants as sp
+from smartypants import smartypants as sp
+from smartypants import Attr
class SmartyPantsTestCase(unittest.TestCase):
diff --git a/tests/test_cli.py b/tests/test_cli.py
index 69b9e4d..263f319 100644
--- a/tests/test_cli.py
+++ b/tests/test_cli.py
@@ -2,11 +2,11 @@
# Licensed under the BSD License, for detailed license information, see COPYING
from __future__ import unicode_literals
+
import os
-from subprocess import Popen, PIPE
import tempfile
import unittest
-
+from subprocess import PIPE, Popen
CLI_SCRIPT = './smartypants'
diff --git a/tests/test_deprecated.py b/tests/test_deprecated.py
index 35c04d8..32e2fbd 100644
--- a/tests/test_deprecated.py
+++ b/tests/test_deprecated.py
@@ -6,7 +6,9 @@ import unittest
import warnings
import smartypants as sps
-from smartypants import Attr, smartypants as sp, smartyPants as sP
+from smartypants import smartypants as sp
+from smartypants import smartyPants as sP
+from smartypants import Attr
class SmartyPantsDeprecatedTestCase(unittest.TestCase):
diff --git a/tests/test_setup.py b/tests/test_setup.py
index ed6a390..e5eb654 100644
--- a/tests/test_setup.py
+++ b/tests/test_setup.py
@@ -1,9 +1,10 @@
# Copyright (c) 2013 Yu-Jie Lin
# Licensed under the BSD License, for detailed license information, see COPYING
-from docutils.core import publish_string
import unittest
+from docutils.core import publish_string
+
class SetupTestCase(unittest.TestCase):