summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/pythonpackage.yml6
-rw-r--r--README.md2
-rw-r--r--doc/source/intro.rst2
-rwxr-xr-xsetup.py3
-rw-r--r--smmap/buf.py2
-rw-r--r--tox.ini2
6 files changed, 8 insertions, 9 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index e6e68ff..9e2d881 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -15,14 +15,14 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9", "3.10"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11"]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
with:
fetch-depth: 1000
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Install dependencies
diff --git a/README.md b/README.md
index f083dd0..e21f534 100644
--- a/README.md
+++ b/README.md
@@ -27,7 +27,7 @@ For performance critical 64 bit applications, a simplified version of memory map
## Prerequisites
-* Python 3.6+
+* Python 3.7+
* OSX, Windows or Linux
The package was tested on all of the previously mentioned configurations.
diff --git a/doc/source/intro.rst b/doc/source/intro.rst
index 3489b04..109fec2 100644
--- a/doc/source/intro.rst
+++ b/doc/source/intro.rst
@@ -20,7 +20,7 @@ For performance critical 64 bit applications, a simplified version of memory map
#############
Prerequisites
#############
-* Python 3.6+
+* Python 3.7+
* OSX, Windows or Linux
The package was tested on all of the previously mentioned configurations.
diff --git a/setup.py b/setup.py
index 9ab8a7f..1df3b62 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ setup(
license="BSD",
packages=find_packages(),
zip_safe=True,
- python_requires=">=3.6",
+ python_requires=">=3.7",
classifiers=[
"Development Status :: 5 - Production/Stable",
"Environment :: Console",
@@ -38,7 +38,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
diff --git a/smmap/buf.py b/smmap/buf.py
index ad27b69..731b064 100644
--- a/smmap/buf.py
+++ b/smmap/buf.py
@@ -93,7 +93,7 @@ class SlidingWindowMapBuffer:
d = d.tobytes()
md.append(d)
# END while there are bytes to read
- return bytes().join(md)
+ return b''.join(md)
# END fast or slow path
#{ Interface
diff --git a/tox.ini b/tox.ini
index c34ab02..810badd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
-envlist = flake8, py36, py37, py38, py39, py310
+envlist = flake8, py{37, 38, 39, 310, 311}
[testenv]
commands = {envpython} -m pytest --cov smmap --cov-report xml {posargs}