summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--requirements.txt1
-rwxr-xr-xsetup.py3
3 files changed, 4 insertions, 2 deletions
diff --git a/README.md b/README.md
index 175bc34..c7a3817 100644
--- a/README.md
+++ b/README.md
@@ -80,7 +80,7 @@ Issues can be filed on github:
A link to the pypi page related to this repository:
-* https://pypi.org/project/smmap/
+* https://pypi.org/project/smmap2/
## License Information
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 0000000..6fa271c
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1 @@
+smmap>=3
diff --git a/setup.py b/setup.py
index ea02f45..074ab84 100755
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ else:
long_description = "See https://github.com/gitpython-developers/smmap"
setup(
- name="smmap",
+ name="smmap2",
version=smmap.__version__,
description="A pure Python implementation of a sliding window memory map manager",
author=smmap.__author__,
@@ -25,6 +25,7 @@ setup(
platforms=["any"],
license="BSD",
packages=find_packages(),
+ install_requires=['smmap>=3'],
zip_safe=True,
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
classifiers=[