summaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorTakeshi KOMIYA <i.tkomiya@gmail.com>2020-02-23 16:35:43 +0900
committerTakeshi KOMIYA <i.tkomiya@gmail.com>2020-02-23 16:36:38 +0900
commit5572eb7b9ea3e761c74688c73e60d2749144a87f (patch)
tree74d51941881fdd66477152d660f73801a5068f3a /utils
parent583667701e955e354082a60e9305e77252a4c351 (diff)
downloadsphinx-git-5572eb7b9ea3e761c74688c73e60d2749144a87f.tar.gz
Makefile: clean dists directory on "make clean"
Diffstat (limited to 'utils')
-rw-r--r--utils/release-checklist16
1 files changed, 8 insertions, 8 deletions
diff --git a/utils/release-checklist b/utils/release-checklist
index 12cbe6381..c29e85707 100644
--- a/utils/release-checklist
+++ b/utils/release-checklist
@@ -12,8 +12,8 @@ for stable releases
* ``git commit -am 'Bump to X.Y.Z final'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.Z``
* ``python utils/bump_version.py --in-develop X.Y.Zb0`` (ex. 1.5.3b0)
@@ -40,8 +40,8 @@ for first beta releases
* ``git commit -am 'Bump to X.Y.0 beta1'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0b1``
* ``python utils/bump_version.py --in-develop X.Y.0b2`` (ex. 1.6.0b2)
@@ -71,8 +71,8 @@ for other beta releases
* ``git commit -am 'Bump to X.Y.0 betaN'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0bN``
* ``python utils/bump_version.py --in-develop X.Y.0bM`` (ex. 1.6.0b3)
@@ -101,8 +101,8 @@ for major releases
* ``git commit -am 'Bump to X.Y.0 final'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0``
* ``python utils/bump_version.py --in-develop X.Y.1b0`` (ex. 1.6.1b0)