summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortk0miya <i.tkomiya@gmail.com>2014-11-27 16:34:44 +0900
committertk0miya <i.tkomiya@gmail.com>2014-11-27 16:34:44 +0900
commit342db7005e995217689abfb8ecca55c302b10bae (patch)
treee2c8d885ebd04af4cb9e6a4dd0595580832c7921
parentf502ea964f547455fa1274d9f12c053d70c74689 (diff)
parentaab4cf35add0081c26c4ef32efaa747014f4c8f7 (diff)
downloadsphinx-342db7005e995217689abfb8ecca55c302b10bae.tar.gz
Merge heads
-rw-r--r--CHANGES1
-rw-r--r--setup.py4
-rw-r--r--sphinx/builders/__init__.py1
-rw-r--r--sphinx/environment.py2
4 files changed, 6 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 3411444f..c9c30609 100644
--- a/CHANGES
+++ b/CHANGES
@@ -16,6 +16,7 @@ Bugs fixed
* PR#311: sphinx-quickstart does not work on python 3.4.
* Fix :confval:`autodoc_docstring_signature` not working with signatures
in class docstrings.
+* Rebuilding cause crash unexpectedly when source files were added.
* #1607: Fix a crash when building latexpdf with "howto" class
diff --git a/setup.py b/setup.py
index 9e000d5c..19451fb2 100644
--- a/setup.py
+++ b/setup.py
@@ -174,7 +174,11 @@ setup(
'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 3',
+ 'Framework :: Sphinx',
+ 'Framework :: Sphinx :: Extension',
+ 'Framework :: Sphinx :: Theme',
'Topic :: Documentation',
+ 'Topic :: Documentation :: Sphinx',
'Topic :: Text Processing',
'Topic :: Utilities',
],
diff --git a/sphinx/builders/__init__.py b/sphinx/builders/__init__.py
index 64ae2a09..70ec6cb5 100644
--- a/sphinx/builders/__init__.py
+++ b/sphinx/builders/__init__.py
@@ -244,7 +244,6 @@ class Builder(object):
if summary:
self.info(bold('building [%s]' % self.name) + ': ' + summary)
- updated_docnames = set()
# while reading, collect all warnings from docutils
warnings = []
self.env.set_warnfunc(lambda *args: warnings.append(args))
diff --git a/sphinx/environment.py b/sphinx/environment.py
index c3d67d73..42327354 100644
--- a/sphinx/environment.py
+++ b/sphinx/environment.py
@@ -590,7 +590,7 @@ class BuildEnvironment:
self.app = None
app.emit('env-updated', self)
- return docnames
+ return set(docnames)
def _read_serial(self, docnames, app):
for docname in app.status_iterator(docnames, 'reading sources... ',