summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2009-02-22 19:00:36 +0100
committerGeorg Brandl <georg@python.org>2009-02-22 19:00:36 +0100
commit8041e28a58f85edac09ce74722a656f09de95a78 (patch)
treed332b2cdab4eb50ee540d232a5e98e0adaae1cd4 /Makefile
parent8c06d1be5c28a7fc1d2511d4601430ef15ef0cd1 (diff)
downloadsphinx-8041e28a58f85edac09ce74722a656f09de95a78.tar.gz
Add makefile target for easy test coverage checking.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4d5048d1..108ed96d 100644
--- a/Makefile
+++ b/Makefile
@@ -30,3 +30,6 @@ reindent:
test:
@cd tests; $(PYTHON) run.py -d -m '^[tT]est' $(TEST)
+
+covertest:
+ @cd tests; $(PYTHON) run.py -d -m '^[tT]est' --with-coverage --cover-package=sphinx $(TEST)