summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Waltman <jonathan.waltman@gmail.com>2012-11-03 12:29:55 -0500
committerJon Waltman <jonathan.waltman@gmail.com>2012-11-03 12:29:55 -0500
commit5c16a29d0d0b679713aa3189db11a64f48265e5f (patch)
treea42656a0ec5a795a153ece4f9194dfa0c5abb972 /setup.py
parent5f25f6236ffb07ff109956bd14eb32f8f1d8c2cc (diff)
downloadsphinx-5c16a29d0d0b679713aa3189db11a64f48265e5f.tar.gz
setup.py: Update "requires" to docutils>=0.10.0 under Python 3.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 3 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 43a072b2..cefb3b89 100644
--- a/setup.py
+++ b/setup.py
@@ -46,21 +46,13 @@ A development egg can be found `here
requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
+if sys.version_info[:3] >= (3, 3, 0):
+ requires[2] = 'docutils>=0.10'
+
if sys.version_info < (2, 5):
print('ERROR: Sphinx requires at least Python 2.5 to run.')
sys.exit(1)
-if sys.version_info[:3] >= (3, 3, 0):
- try:
- import docutils
- x, y = docutils.__version__.split('.')[:2]
- if (int(x), int(y)) < (0, 10):
- sys.stderr.write('ERROR: Sphinx requires at least '
- 'Docutils 0.10 for Python 3.3 and above.\n')
- sys.exit(1)
- except Exception:
- pass
-
# Provide a "compile_catalog" command that also creates the translated
# JavaScript files if Babel is available.