summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2014-01-22 18:13:49 +0100
committerGeorg Brandl <georg@python.org>2014-01-22 18:13:49 +0100
commit6f75873b602864ebfd4512c79785d567e253860f (patch)
treeb0b6fc2d8bc99bb63e544f843cc9763a9798ed4f /setup.py
parent1959d681ce28792585032a1090fe31157e8bbfa1 (diff)
parentdb07af36867c5da22160637cd535d32d20d69d28 (diff)
downloadsphinx-6f75873b602864ebfd4512c79785d567e253860f.tar.gz
merge with stable
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 876c0782..21f6709e 100644
--- a/setup.py
+++ b/setup.py
@@ -41,20 +41,20 @@ Among its features are the following:
* Setuptools integration
'''
+if sys.version_info < (2, 6) or (3, 0) <= sys.version_info < (3, 2):
+ print('ERROR: Sphinx requires at least Python 2.6 or 3.2 to run.')
+ sys.exit(1)
+
requires = ['Pygments>=1.2', 'docutils>=0.7']
if sys.version_info[:3] >= (3, 3, 0):
requires[1] = 'docutils>=0.10'
-if sys.version_info < (2, 6) or (3, 0) <= sys.version_info < (3, 3):
+if (3, 0) <= sys.version_info < (3, 3):
requires.append('Jinja2>=2.3,<2.7')
-else:
+else: # 2.6, 2.7, 3.3 or later
requires.append('Jinja2>=2.3')
-if sys.version_info < (2, 5):
- print('ERROR: Sphinx requires at least Python 2.5 to run.')
- sys.exit(1)
-
# tell distribute to use 2to3 with our own fixers
extra = {}
if sys.version_info >= (3, 0):