summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2012-10-30 09:55:44 +0100
committerGeorg Brandl <georg@python.org>2012-10-30 09:55:44 +0100
commit889c2609637fc1d64935e5bcdc537120768d876e (patch)
tree90f0bbf154505da55010419e80ae41923accdaf6 /setup.py
parentb694161cd3da8e6667570b2beaf730f24ee86e67 (diff)
downloadsphinx-889c2609637fc1d64935e5bcdc537120768d876e.tar.gz
Update required Python to 2.5.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 2 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index ca41aa43..720dc77b 100644
--- a/setup.py
+++ b/setup.py
@@ -46,25 +46,9 @@ A development egg can be found `here
requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
-if sys.version_info < (2, 4):
- print('ERROR: Sphinx requires at least Python 2.4 to run.')
- sys.exit(1)
-
if sys.version_info < (2, 5):
- # Python 2.4's distutils doesn't automatically install an egg-info,
- # so an existing docutils install won't be detected -- in that case,
- # remove the dependency from setup.py
- try:
- import docutils
- if int(docutils.__version__[2]) < 4:
- raise ValueError('docutils not recent enough')
- except:
- pass
- else:
- del requires[-1]
-
- # The uuid module is new in the stdlib in 2.5
- requires.append('uuid>=1.30')
+ print('ERROR: Sphinx requires at least Python 2.5 to run.')
+ sys.exit(1)
# Provide a "compile_catalog" command that also creates the translated