summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Neuh?user <dasdasich@gmail.com>2010-05-08 20:34:19 +0200
committerDaniel Neuh?user <dasdasich@gmail.com>2010-05-08 20:34:19 +0200
commite3819e0971b3036e5cc8a8ececf097782093257d (patch)
treeb8b19b96b02ac70d5729bc58b0bb805575a221d3 /setup.py
parentd3771a017c17bbc63f89cd6be0e321db490df222 (diff)
downloadsphinx-e3819e0971b3036e5cc8a8ececf097782093257d.tar.gz
Removed ez_setup which doesn't work with python3 and added use_2to3 for distribute
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 183fcceb..2494851f 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ A development egg can be found `here
requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5']
if sys.version_info < (2, 4):
- print 'ERROR: Sphinx requires at least Python 2.4 to run.'
+ print('ERROR: Sphinx requires at least Python 2.4 to run.')
sys.exit(1)
if sys.version_info < (2, 5):
@@ -198,4 +198,5 @@ setup(
},
install_requires=requires,
cmdclass=cmdclass,
+ use_2to3=True,
)