summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorStephen Finucane <stephenfin@redhat.com>2021-12-15 10:10:21 +0000
committerStephen Finucane <stephenfin@redhat.com>2021-12-15 10:36:51 +0000
commit6340268cad342f41c357604535c842f5df1d4a10 (patch)
tree1fbdd00192065005474583ed463965535d3e69fb /pyproject.toml
parentc87ffbd904627d777aa1430963dced92a36aa033 (diff)
downloadsubunit-git-6340268cad342f41c357604535c842f5df1d4a10.tar.gz
Drop support for Python 2.7, 3.5
Both of these are EOL now. There's no reason to continue supporting them. Python 3.6 is close to EOL but we can give it another release before we formally drop that. We also drop support for installing without setuptools, since this is expected to be effectively always present nowadays. We include a pyproject.toml file just in case that ever changes though. Signed-off-by: Stephen Finucane <stephenfin@redhat.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9ebf206
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,5 @@
+[build-system]
+# These are the assumed default build requirements from pip:
+# https://pip.pypa.io/en/stable/reference/pip/#pep-517-and-518-support
+requires = ["setuptools>=43.0.0", "wheel"]
+build-backend = "setuptools.build_meta"