summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-11-24 12:01:37 +1300
committerRobert Collins <robertc@robertcollins.net>2013-11-24 12:01:37 +1300
commited03e3e83be5191c58de68fc1d3a04e416160d50 (patch)
treefb0a28f5965f6ecbe084b4d152d4b2105122cd80
parent7262d3823e8435b7ca9af2226ba49c5029393a38 (diff)
downloadsubunit-ed03e3e83be5191c58de68fc1d3a04e416160d50.tar.gz
* Perl files should now honour perl system config.
(Benedikt Morbach, #1233198) With INSTALL_BASE, perl files are unconditionally installed to ${prefix}/lib/perl5/ instead of respecting the system-dependent perl library path that is set when perl is installed. (sitelib/vendorlib) If INSTALL_BASE is changed to PREFIX, it correctly finds the path where it should install via perl's Config.pm
-rw-r--r--NEWS3
-rwxr-xr-xperl/Makefile.PL.in2
2 files changed, 4 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index 380eb6c..b7f24bf 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,9 @@ NEXT (In development)
BUG FIXES
~~~~~~~~~
+* Perl files should now honour perl system config.
+ (Benedikt Morbach, #1233198)
+
* Python 3.1 and 3.2 have an inconsistent memoryview implementation which
required a workaround for NUL byte detection. (Robert Collins, #1216246)
diff --git a/perl/Makefile.PL.in b/perl/Makefile.PL.in
index cf5e6c4..9289594 100755
--- a/perl/Makefile.PL.in
+++ b/perl/Makefile.PL.in
@@ -1,6 +1,6 @@
use ExtUtils::MakeMaker;
WriteMakefile(
- 'INSTALL_BASE' => '@prefix@',
+ 'PREFIX' => '@prefix@',
'NAME' => 'Subunit',
'VERSION' => '@SUBUNIT_VERSION@',
'test' => { 'TESTS' => 'tests/*.pl' },