summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-10-03 23:33:53 +1000
committerRobert Collins <robertc@robertcollins.net>2009-10-03 23:33:53 +1000
commitb50bdb5176e02b2ea0521f79ab7f03bf368a6609 (patch)
tree6b8b21aa693bd783626ca3cec772fd1f987b678c /Makefile.am
parentc7f265a53291e4966cdbee933730e5b97ce332b9 (diff)
downloadsubunit-b50bdb5176e02b2ea0521f79ab7f03bf368a6609.tar.gz
Move the C++ Listener from a patch against cppunit to a usable external module for cppunit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f6a4eff..58068e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,9 @@ ACLOCAL_AMFLAGS = -I m4
SUBUNIT_CFLAGS = -Wall -Werror -Wextra -Wstrict-prototypes -Wmissing-prototypes \
-Wwrite-strings -Wno-variadic-macros -I$(top_srcdir)/c/include
AM_CFLAGS = $(SUBUNIT_CFLAGS)
+SUBUNIT_CXXFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-variadic-macros \
+ -I$(top_srcdir)/c/include
+AM_CXXFLAGS = $(SUBUNIT_CXXFLAGS)
include_subunitdir = $(includedir)/subunit
@@ -67,9 +70,11 @@ pkgpython_PYTHON = \
python/subunit/test_results.py
lib_LTLIBRARIES = libsubunit.la
+lib_LTLIBRARIES += libcppunit_subunit.la
include_subunit_HEADERS = \
- c/include/subunit/child.h
+ c/include/subunit/child.h \
+ c++/SubunitTestProgressListener.h
check_PROGRAMS = \
c/tests/test_child
@@ -81,6 +86,10 @@ libsubunit_la_SOURCES = \
c/lib/child.c \
c/include/subunit/child.h
+libcppunit_subunit_la_SOURCES = \
+ c++/SubunitTestProgressListener.cpp \
+ c++/SubunitTestProgressListener.h
+
tests_LDADD = @CHECK_LIBS@ $(top_builddir)/libsubunit.la
c_tests_test_child_CFLAGS = $(SUBUNIT_CFLAGS) @CHECK_CFLAGS@
c_tests_test_child_LDADD = $(tests_LDADD)