summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@agendaless.com>2010-06-02 20:18:00 -0400
committerTres Seaver <tseaver@agendaless.com>2010-06-02 20:18:00 -0400
commit4672d0fdc526d46d92cf93428bf1aef5884bca13 (patch)
treec38dcb826a8336f2af24db0dde0b9876800ddd26 /setup.py
parent4cbec79b1c2821923ee10bba12b6c05e0bab53c7 (diff)
downloadsubunit-4672d0fdc526d46d92cf93428bf1aef5884bca13.tar.gz
Add distutils / setuptools installation support for Python libs / scripts.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py58
1 files changed, 58 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..40edf9a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,58 @@
+try:
+ # If the user has setuptools / distribute installed, use it
+ from setuptools import setup
+except ImportError:
+ # Otherwise, fall back to distutils.
+ from distutils.core import setup
+ extra = {}
+else:
+ extra = {
+ 'install_requires': [
+ 'testtools',
+ ]
+ }
+
+try:
+ # Assume we are in a distribution, which has PKG-INFO
+ version_lines = [x for x in open('PKG-INFO').readlines()
+ if x.startswith('Version:')]
+ version_line = version_lines and version_lines[-1] or 'VERSION = 0.0'
+ VERSION = version_line.split(':')[1].strip()
+
+except IOError:
+ # Must be a development checkout, so use the Makefile
+ version_lines = [x for x in open('Makefile').readlines()
+ if x.startswith('VERSION')]
+ version_line = version_lines and version_lines[-1] or 'VERSION = 0.0'
+ VERSION = version_line.split('=')[1].strip()
+
+
+setup(
+ name='subunit-python',
+ version=VERSION,
+ description=('Python implementation of subunit test streaming protocol'),
+ long_description=open('README').read(),
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Testing',
+ ],
+ keywords='python test streaming',
+ author='Robert Collins',
+ author_email='subunit-dev@lists.launchpad.net',
+ url='http://launchpad.net/subunit',
+ packages=['subunit'],
+ package_dir={'subunit': 'python/subunit'},
+ scripts = [
+ 'filters/subunit2gtk',
+ 'filters/subunit2junitxml',
+ 'filters/subunit2pyunit',
+ 'filters/subunit-filter',
+ 'filters/subunit-ls',
+ 'filters/subunit-notify',
+ 'filters/subunit-stats',
+ 'filters/subunit-tags',
+ 'filters/tap2subunit',
+ ],
+ **extra
+)