diff options
-rw-r--r-- | README | 6 | ||||
-rwxr-xr-x | setup.py | 2 |
2 files changed, 5 insertions, 3 deletions
@@ -462,9 +462,9 @@ Releases ======== * Update versions in configure.ac and python/subunit/__init__.py. -* Update Makefile in the root or do an inplace configure to get an updated Makefile. * Update NEWS. -* Make PyPI and regular tarball releases. Upload the regular one to LP, the - PyPI one to PyPI. +* Do a make distcheck, which will update Makefile etc. +* Do a PyPI release: PYTHONPATH=../../python python ../../setup.py sdist upload -s +* Upload the regular one to LP. * Push a tagged commit. @@ -1,4 +1,5 @@ #!/usr/bin/env python +import os.path try: # If the user has setuptools / distribute installed, use it from setuptools import setup @@ -33,6 +34,7 @@ VERSION = ( or "0.0") +os.chdir(os.path.dirname(__file__)) setup( name='python-subunit', version=VERSION, |