summaryrefslogtreecommitdiff
path: root/makefile
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2008-10-27 20:30:52 +0000
committerjortel <devnull@localhost>2008-10-27 20:30:52 +0000
commit42f7c996c3e63889c1332d9ce7e833034e34449c (patch)
tree09df20078445758a0c7f24710912ccb2a1b09c95 /makefile
parent269be42842cb0097b996a02c4103f13d729f007c (diff)
downloadsuds-42f7c996c3e63889c1332d9ce7e833034e34449c.tar.gz
clean /usr/src/redhat/** in clean target; add Element.insert()
Diffstat (limited to 'makefile')
-rw-r--r--makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/makefile b/makefile
index c7c6293..5f8d42a 100644
--- a/makefile
+++ b/makefile
@@ -29,7 +29,7 @@ dist: clean
sed -e "s/name=\"suds\"/name=\"python-suds\"/" $(SETUP) > $(pythonSETUP)
python $(SETUP) sdist bdist_egg
python $(pythonSETUP) sdist bdist_egg
- scp dist/python-*.gz fedorahosted.org:suds
+ scp dist/python* fedorahosted.org:suds
rm -rf *.egg-info
rm -f $(pythonSETUP)
@@ -38,6 +38,7 @@ rpm: dist
rpmbuild -ba $(SPEC)
cp /usr/src/redhat/RPMS/noarch/python-suds*.rpm dist
cp /usr/src/redhat/SRPMS/python-suds*.rpm dist
+ scp dist/python*.rpm fedorahosted.org:suds
register: FORCE
python setup.py sdist bdist_egg register upload
@@ -46,6 +47,10 @@ clean: FORCE
rm -rf dist
rm -rf build
rm -rf *.egg-info
+ rm -rf /usr/src/redhat/BUILD/python-suds*
+ rm -rf /usr/src/redhat/RPMS/noarch/python-suds*
+ rm -rf /usr/src/redhat/SOURCES/python-suds*
+ rm -rf /usr/src/redhat/SRPMS/python-suds*
find . -name "*.pyc" -exec rm -f {} \;
find . -name "*~" -exec rm -f {} \;