summaryrefslogtreecommitdiff
path: root/makefile
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2008-09-11 17:49:35 +0000
committerjortel <devnull@localhost>2008-09-11 17:49:35 +0000
commit867e1956eae27d2196675e3b40ddeb6076b800f4 (patch)
tree1f149bd7a1069211b58d326bd7e9ea64589cf88a /makefile
parent907d987287b4537102b385da5e96a9efd974f89f (diff)
downloadsuds-867e1956eae27d2196675e3b40ddeb6076b800f4.tar.gz
Diffstat (limited to 'makefile')
-rw-r--r--makefile54
1 files changed, 32 insertions, 22 deletions
diff --git a/makefile b/makefile
index b4d8edf..82377e0 100644
--- a/makefile
+++ b/makefile
@@ -15,42 +15,52 @@
# written by: Jeff Ortel ( jortel@redhat.com )
#
+SPEC = suds.spec
+PUBSPEC = .pubsuds.spec
+SETUP = setup.py
+PUBSETUP = .pubsetup.py
+
all: rpm tar egg
-dist: clean
- python setup.py sdist
+egg: clean
+ sed -e "s/python-suds/suds/g" $(SETUP) > $(PUBSETUP)
+ python $(PUBSETUP) bdist_egg
rm -rf *.egg-info
+ rm -f $(PUBSETUP)
-egg: FORCE
- python setup.py bdist_egg
- cd dist; mv *.egg `ls *.egg|cut -c8-`
+pdist: clean
+ sed -e "s/python-suds/suds/g" $(SETUP) > $(PUBSETUP)
+ python $(PUBSETUP) sdist
rm -rf *.egg-info
+ rm -f $(PUBSETUP)
-tar: dist
- cd dist; \
- rm -rf tmp; \
- mkdir tmp; \
- cd tmp; \
- tar xzvf ../*.gz; \
- cd `ls`; \
- tar czvf ../../`ls ../|cut -c8-`.tar.gz *
- rm -rf dist/tmp
+dist: clean
+ python $(SETUP) sdist
+ rm -rf *.egg-info
rpm: dist
- cp dist/*.gz /usr/src/redhat/SOURCES
- cp suds.spec /usr/src/redhat/SPECS
- rpmbuild -ba suds.spec
- cp /usr/src/redhat/RPMS/noarch/*.rpm dist
- cp /usr/src/redhat/SRPMS/*.rpm dist
+ cp dist/python-suds*.gz /usr/src/redhat/SOURCES
+ rpmbuild -ba $(SPEC)
+ cp /usr/src/redhat/RPMS/noarch/python-suds*.rpm dist
+ cp /usr/src/redhat/SRPMS/python-suds*.rpm dist
+
+prpm: pdist
+ cp dist/suds*.gz /usr/src/redhat/SOURCES
+ sed -e "s/python-suds/suds/g;s/$(SETUP)/$(PUBSETUP)/g" $(SPEC) > $(PUBSPEC)
+ rpmbuild -ba $(PUBSPEC)
+ cp /usr/src/redhat/RPMS/noarch/suds*.rpm dist
+ cp /usr/src/redhat/SRPMS/suds*.rpm dist
+ rm -f $(PUBSPEC)
register: FORCE
- sed -e "s/python-suds/suds/g" setup.py > reg.py
- python reg.py register
- rm -f reg.py
+ sed -e "s/python-suds/suds/g" $(SETUP) > $(PUBSETUP)
+ python $(PUBSETUP) register
+ rm -f $(PUBSETUP)
clean: FORCE
rm -rf dist
rm -rf *.egg-info
find . -name "*.pyc" -exec rm -f {} \;
+ rm -f $(PUBSETUP) $(PUBSPEC)
FORCE: