summaryrefslogtreecommitdiff
path: root/python-suds.spec
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2008-10-24 17:55:44 +0000
committerjortel <devnull@localhost>2008-10-24 17:55:44 +0000
commit7c35be552d5ae6a2e212302ce840e9eaaa7fabbe (patch)
treec09417de04962f642ee6f26ed09c3d604bf048d7 /python-suds.spec
parentdee308f730713cceec97f0b2909dbce174c7d332 (diff)
downloadsuds-7c35be552d5ae6a2e212302ce840e9eaaa7fabbe.tar.gz
updated trunk with fedora review comments
Diffstat (limited to 'python-suds.spec')
-rw-r--r--python-suds.spec40
1 files changed, 26 insertions, 14 deletions
diff --git a/python-suds.spec b/python-suds.spec
index ef5a689..0dcdc31 100644
--- a/python-suds.spec
+++ b/python-suds.spec
@@ -1,11 +1,9 @@
-%define name python-suds
-%define version 0.3.2
-%define release 1
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Summary: A python SOAP client
-Name: %{name}
-Version: %{version}
-Release: %{release}
+Name: python-suds
+Version: 0.3.2
+Release: 1
Source0: %{name}-%{version}.tar.gz
License: LGPLv3+
Group: Development/Libraries
@@ -20,12 +18,12 @@ BuildRequires: python-setuptools
Url: https://fedorahosted.org/suds
%description
- The suds project is a python soap web services client lib. Suds leverages
- python meta programming to provide an intuative API for consuming web
- services. Objectification of types defined in the WSDL is provided
- without class generation. Programmers rarely need to read the WSDL since
- services and WSDL based objects can be easily inspected. Supports
- pluggable soap bindings.
+The suds project is a python soap web services client lib. Suds leverages
+python meta programming to provide an intuative API for consuming web
+services. Objectification of types defined in the WSDL is provided
+without class generation. Programmers rarely need to read the WSDL since
+services and WSDL based objects can be easily inspected. Supports
+pluggable soap bindings.
%prep
%setup -q
@@ -39,12 +37,26 @@ python setup.py install --optimize=1 --root=$RPM_BUILD_ROOT --record=INSTALLED_F
%clean
rm -rf $RPM_BUILD_ROOT
-%files -f INSTALLED_FILES
+%files
+%defattr(-,root,root,-)
+%if 0%{?fedora} >= 8
+%{python_sitelib}/suds*.egg-info
+%endif
+%dir %{python_sitelib}/suds
+%dir %{python_sitelib}/suds/bindings
+%dir %{python_sitelib}/suds/sax
+%dir %{python_sitelib}/suds/xsd
+%dir %{python_sitelib}/tests
+%{python_sitelib}/suds/*.py*
+%{python_sitelib}/suds/bindings/*.py*
+%{python_sitelib}/suds/sax/*.py*
+%{python_sitelib}/suds/xsd/*.py*
+%{python_sitelib}/tests/*.py*
%doc README
%changelog
- * Fri Oct 10 2008 jortel <jortel@redhat.com> - release 0.3.1-1
+ * Fri Oct 10 2008 jortel <jortel@redhat.com> - 0.3.1-1
- Extends the support for multi-port services introduced earlier. This addition,
provides for multiple services to define the *same* method and suds will
handle it properly. See section 'SERVICES WITH MULTIPLE PORTS:'