summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-12-19 09:45:30 +1100
committerRobert Collins <robertc@robertcollins.net>2009-12-19 09:45:30 +1100
commita7b16c720bc9d62222c72d2f9fb268a88a51162a (patch)
treef16cc206ce2f07d44e98da67f8cdde3293ba0b1b /Makefile
downloadtestrepository-git-a7b16c720bc9d62222c72d2f9fb268a88a51162a.tar.gz
Base project infrastructure.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..392f8ec
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2009 Testrepository Contributors
+#
+# Licensed under either the Apache License, Version 2.0 or the BSD 3-clause
+# license at the users choice. A copy of both licenses are available in the
+# project source as Apache-2.0 and BSD. You may not use this file except in
+# compliance with one of these two licences.
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under these licenses is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# license you chose for the specific language governing permissions and
+# limitations under that license.
+
+all: check
+
+check:
+ python -m testtools.run testrepository.tests.test_suite
+
+release:
+ ./setup.py sdist upload --sign
+
+.PHONY: check