summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-12-28 07:49:31 +1100
committerRobert Collins <robertc@robertcollins.net>2009-12-28 07:49:31 +1100
commitac53b0a3855bedac1c203d00fe95fef787dfa966 (patch)
tree4feba7aa71179a48f94a6ac403553d17cf405db9 /Makefile
parenta29f9ffcdb410a2b915754a19cdb575e221a7cf8 (diff)
downloadtestrepository-git-ac53b0a3855bedac1c203d00fe95fef787dfa966.tar.gz
Return stream status from load, and change make to use testr itself.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 56c2046..97721e4 100644
--- a/Makefile
+++ b/Makefile
@@ -14,8 +14,11 @@
all: check
-check:
- python -m testtools.run testrepository.tests.test_suite
+.testrepository:
+ ./testr init
+
+check: .testrepository
+ python -m subunit.run testrepository.tests.test_suite | ./testr load
check-xml:
python -m subunit.run testrepository.tests.test_suite | subunit2junitxml -o test.xml -f | subunit2pyunit