summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2014-03-11 22:01:07 -0700
committerRobert Collins <robertc@robertcollins.net>2015-07-12 21:29:28 +1200
commite3ae38038a267e1982c4cf1eb4e759f43aaf7f8f (patch)
tree317e4808c1ca7afd5b2e3bdf293f4132cd0c8869 /Makefile
parent4eb428d26fa43bdd87be37652a11aad73a707825 (diff)
downloadtestrepository-git-e3ae38038a267e1982c4cf1eb4e759f43aaf7f8f.tar.gz
Migrate to pbr for build management
Reduce manual maintenance by using pbr.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index b05b894..57ec722 100644
--- a/Makefile
+++ b/Makefile
@@ -14,10 +14,13 @@
all: README.txt check
+editable:
+ pip install -e .[test]
+
.testrepository:
./testr init
-check: .testrepository
+check: editable .testrepository
./testr run --parallel
check-xml:
@@ -26,7 +29,7 @@ check-xml:
release:
./setup.py sdist upload --sign
-README.txt: testrepository/commands/quickstart.py
+README.txt: editable testrepository/commands/quickstart.py
./testr quickstart > $@
-.PHONY: check check-xml release all
+.PHONY: check check-xml editable release all