summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-01-15 19:43:42 +1300
committerRobert Collins <robertc@robertcollins.net>2013-01-15 19:43:42 +1300
commit30327b0dd840cfa0ea1311f4c3697056689a7b28 (patch)
treea14c46390ced6bad54eeb08447e49cc2e7dfc04b
parenta8e90d02178681f200ccd7640e98d77bd9b8e940 (diff)
parent7e4ae057fe6a3290c764a18ffff119f318101c14 (diff)
downloadtestrepository-30327b0dd840cfa0ea1311f4c3697056689a7b28.tar.gz
* ``setup.py testr`` was not indicating test failures via it's return code.
(Monty Taylor)
-rw-r--r--NEWS6
-rw-r--r--testrepository/setuptools_command.py4
2 files changed, 8 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 56d8860..2b63671 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,12 @@ testrepository release notes
NEXT (In development)
+++++++++++++++++++++
+IMPROVEMENTS
+------------
+
+* ``setup.py testr`` was not indicating test failures via it's return code.
+ (Monty Taylor)
+
0.0.12
++++++
diff --git a/testrepository/setuptools_command.py b/testrepository/setuptools_command.py
index bfb5277..2718e3e 100644
--- a/testrepository/setuptools_command.py
+++ b/testrepository/setuptools_command.py
@@ -48,8 +48,8 @@ class Testr(cmd.Command):
boolean_options = ['coverage', 'slowest']
def _run_testr(self, *args):
- commands.run_argv([sys.argv[0]] + list(args),
- sys.stdin, sys.stdout, sys.stderr)
+ return commands.run_argv([sys.argv[0]] + list(args),
+ sys.stdin, sys.stdout, sys.stderr)
def initialize_options(self):
self.testr_args = None