summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2010-01-10 00:06:19 +1100
committerRobert Collins <robertc@robertcollins.net>2010-01-10 00:06:19 +1100
commit3a5449cc65104d0c92220455fa647f397df42038 (patch)
treed4798a165e31ae06ce974e5d88d2a83e4d3cdc91 /Makefile
parent6d420043cac2424fc47bc099d917dbfdaa183847 (diff)
downloadtestrepository-3a5449cc65104d0c92220455fa647f397df42038.tar.gz
Add quickstart command.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 97721e4..9c1010a 100644
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@
# license you chose for the specific language governing permissions and
# limitations under that license.
-all: check
+all: README.txt check
.testrepository:
./testr init
@@ -26,4 +26,7 @@ check-xml:
release:
./setup.py sdist upload --sign
+README.txt: testrepository/commands/quickstart.py
+ ./testr quickstart > $@
+
.PHONY: check check-xml release all