summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2010-02-28 21:36:31 +1100
committerRobert Collins <robertc@robertcollins.net>2010-02-28 21:36:31 +1100
commit701519e766e2c1c384d2fa4bf1b7ea1ed8b82dc9 (patch)
tree7dd78a6d0b3b475d778c90b33441972719024e52 /setup.py
parentb580e9b916adf5f4e599c56f1d4994f19e913516 (diff)
downloadtestrepository-701519e766e2c1c384d2fa4bf1b7ea1ed8b82dc9.tar.gz
Release 0.0.3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e4aaebc..6e5d876 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
#
-# Copyright (c) 2009 Testrepository Contributors
+# Copyright (c) 2009, 2010 Testrepository Contributors
#
# Licensed under either the Apache License, Version 2.0 or the BSD 3-clause
# license at the users choice. A copy of both licenses are available in the
@@ -14,7 +14,10 @@
# limitations under that license.
from distutils.core import setup
+import os
+
import testrepository
+
version = '.'.join(str(component) for component in testrepository.__version__[0:3])
phase = testrepository.__version__[3]
if phase != 'final':
@@ -27,11 +30,14 @@ if phase != 'final':
# Preserve the version number but give it a revno prefix
version = version + '~%s' % t.branch.revno()
+description = file(os.path.join(os.path.dirname(__file__), 'README.txt'), 'rb').read()
+
setup(name='testrepository',
author='Robert Collins',
author_email='robertc@robertcollins.net',
url='https://launchpad.net/testrepository',
- description=('A repository of test results.'),
+ description='A repository of test results.',
+ long_description=description,
scripts=['testr'],
version=version,
packages=['testrepository',