summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index bbc9252..c5f61c7 100755
--- a/setup.py
+++ b/setup.py
@@ -3,10 +3,10 @@
from distutils.core import setup
import os.path
-description = file(os.path.join(os.path.dirname(__file__), 'README'), 'rb').read()
+description = open(os.path.join(os.path.dirname(__file__), 'README'), 'rt').read()
setup(name="testresources",
- version="0.2.5",
+ version="0.2.6",
description="Testresources, a pyunit extension for managing expensive "
"test resources",
long_description=description,
@@ -15,6 +15,7 @@ setup(name="testresources",
url="https://launchpad.net/testresources",
packages=['testresources', 'testresources.tests'],
package_dir = {'':'lib'},
+ keywords="unittest testing fixtures",
classifiers = [
'Development Status :: 6 - Mature',
'Intended Audience :: Developers',
@@ -22,6 +23,7 @@ setup(name="testresources",
'License :: OSI Approved :: Apache Software License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
'Topic :: Software Development :: Quality Assurance',
'Topic :: Software Development :: Testing',
],