summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..73a862b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PYTHONPATH:=$(shell pwd)/lib:${PYTHONPATH}
+
+all:
+
+check:
+ PYTHONPATH=$(PYTHONPATH) python ./test_all.py $(TESTRULE)
+
+clean:
+ find . -name '*.pyc' -print0 | xargs -0 rm -f
+
+TAGS: lib/testscenarios/*.py lib/testscenarios/tests/*.py
+ ctags -e -R lib/testscenarios/
+
+tags: lib/testscenarios/*.py lib/testscenarios/tests/*.py
+ ctags -R lib/testscenarios/
+
+.PHONY: all check clean