summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 73a862b..3215623 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,13 @@
PYTHONPATH:=$(shell pwd)/lib:${PYTHONPATH}
+PYTHON ?= python
all:
+# it would be nice to use doctest directly to run the README, but that's
+# only supported from python2.6 onwards, so we need a script
check:
- PYTHONPATH=$(PYTHONPATH) python ./test_all.py $(TESTRULE)
+ PYTHONPATH=$(PYTHONPATH):.:./lib $(PYTHON) run_doctest.py README
+ PYTHONPATH=$(PYTHONPATH) $(PYTHON) ./test_all.py $(TESTRULE)
clean:
find . -name '*.pyc' -print0 | xargs -0 rm -f