summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2015-03-09 22:29:29 +1300
committerRobert Collins <robertc@robertcollins.net>2015-03-10 08:36:16 +1300
commit55278e0e4a935f1d8c468a4d29a8133088806790 (patch)
tree8ebc96cebb6c37c77a37389a8e9d999a06fbdf17 /setup.py
parentedf585e6d5a960097c491daaf1c20d30e998d782 (diff)
downloadtesttools-55278e0e4a935f1d8c468a4d29a8133088806790.tar.gz
Overhaul exception reporting.
unittest2 recently added the ability to show local variables in tracebacks as https://github.com/testing-cabal/testtools/issues/111 requested for us. Reusing that requires some refactoring of our code, in particular where we were reimplementing bits of the traceback module. Now we can just hard-depend on traceback2 and linecache2 which are brought in by unittest2 1.0.0. Change-Id: Ieb3268029d26b48ed4fcd25ed644bd339f6aa3fb
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 95c3b67..5d1f1c5 100755
--- a/setup.py
+++ b/setup.py
@@ -63,7 +63,8 @@ deps = [
# 'mimeparse' has not been uploaded by the maintainer with Python3 compat
# but someone kindly uploaded a fixed version as 'python-mimeparse'.
'python-mimeparse',
- 'unittest2>=0.8.0',
+ 'unittest2>=1.0.0',
+ 'traceback2',
]