summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan Lange <jml@canonical.com>2011-11-25 18:24:10 +0000
committerJonathan Lange <jml@canonical.com>2011-11-25 18:24:10 +0000
commit5bee106e9cf0cfe9ba0336c6fe9c104948848ba3 (patch)
tree1981f4fe46434556ba8fd22b249e89e0f6d55064 /setup.py
parent3cd2a98b7ec6a3f2cf8588c5d218c80e342c5afc (diff)
downloadtesttools-5bee106e9cf0cfe9ba0336c6fe9c104948848ba3.tar.gz
Add the version to the snapshot string
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d07c8f2..0fabb06 100755
--- a/setup.py
+++ b/setup.py
@@ -45,7 +45,10 @@ def get_version():
return pkg_info_version
revno = get_revno()
if revno is None:
- return "snapshot"
+ # Apparently if we just say "snapshot" then distribute won't accept it
+ # as satisfying versioned dependencies. This is a problem for the
+ # daily build version.
+ return "snapshot-%s" % (version,)
if phase == 'alpha':
# No idea what the next version will be
return 'next-r%s' % revno