summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2011-02-28 13:12:03 +0100
committerJelmer Vernooij <jelmer@samba.org>2011-02-28 13:12:03 +0100
commitb86b71d23274504767159fad598f929950d1c976 (patch)
tree66835c4b72434f0cbc7adf338ca7e6b8bee70a7f /setup.py
parentd1ab86e1503d57b2d56d0f25990c1d1dd8f02180 (diff)
downloadtesttools-b86b71d23274504767159fad598f929950d1c976.tar.gz
Catch both NotBranchError /and/ NoworkingTree as different versions of bzr seem to raise a different error.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 19f55ce..d07c8f2 100755
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ def get_revno():
import bzrlib.workingtree
try:
t = bzrlib.workingtree.WorkingTree.open_containing(__file__)[0]
- except bzrlib.errors.NoWorkingTree:
+ except (bzrlib.errors.NotBranchError, bzrlib.errors.NoWorkingTree):
return None
else:
return t.branch.revno()