summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan Lange <jml@canonical.com>2010-09-11 14:44:56 +0100
committerJonathan Lange <jml@canonical.com>2010-09-11 14:44:56 +0100
commitc3cb7e20fa9f3870c53c1011b8e97f52f425136c (patch)
treef753560bfccf44daa290334ce2df46065329bee8 /setup.py
parent0b7f7e3a8e3f49067a28a1879a9c233fb669af59 (diff)
downloadtesttools-c3cb7e20fa9f3870c53c1011b8e97f52f425136c.tar.gz
Set the license and the long description. Useful for publishing to PyPI.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d7ed46f..7f610fd 100755
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,8 @@
"""Distutils installer for testtools."""
from distutils.core import setup
+import os
+
import testtools
version = '.'.join(str(component) for component in testtools.__version__[0:3])
phase = testtools.__version__[3]
@@ -15,11 +17,19 @@ if phase != 'final':
# Preserve the version number but give it a revno prefix
version = version + '~%s' % t.branch.revno()
+
+def get_long_description():
+ manual_path = os.path.join(os.path.dirname(__file__), 'MANUAL')
+ return open(manual_path).read()
+
+
setup(name='testtools',
author='Jonathan M. Lange',
author_email='jml+testtools@mumak.net',
url='https://launchpad.net/testtools',
description=('Extensions to the Python standard library unit testing '
'framework'),
+ long_description=get_long_description(),
version=version,
+ classifiers=["License :: OSI Approved :: MIT License"],
packages=['testtools', 'testtools.testresult', 'testtools.tests'])