summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2013-05-15 18:16:57 -0700
committerGuido van Rossum <guido@python.org>2013-05-15 18:16:57 -0700
commit16c3b01ab4b2f1b70d9a2ea9c14295ac16021fff (patch)
treeab60297dd5dccb81d57a69e9d5639cb8c6aa19c9 /Makefile
parent4358d8bc7ff276335688d41fa075910c0a124715 (diff)
downloadtrollius-16c3b01ab4b2f1b70d9a2ea9c14295ac16021fff.tar.gz
Default "make test" to non-verbose. Add vtest to force verbise.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bca4ed9..11fe52c 100644
--- a/Makefile
+++ b/Makefile
@@ -2,12 +2,15 @@
PYTHON=python3
VERBOSE=$(V)
-V= 1
+V= 0
FLAGS=
test:
$(PYTHON) runtests.py -v $(VERBOSE) $(FLAGS)
+vtest:
+ $(PYTHON) runtests.py -v 1 $(FLAGS)
+
testloop:
while sleep 1; do $(PYTHON) runtests.py -v $(VERBOSE) $(FLAGS); done