summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuido van Rossum <guido@google.com>2012-12-17 20:21:56 -0800
committerGuido van Rossum <guido@google.com>2012-12-17 20:21:56 -0800
commit4e0e1eebaa0e8c10d7f4a1d39bb0ca28fe88589a (patch)
treeb6b68e66612e33bbe9a7c2c238e8151758d5597d /Makefile
parent3427a3918496ed391d47716af7945da362b1f045 (diff)
downloadtrollius-4e0e1eebaa0e8c10d7f4a1d39bb0ca28fe88589a.tar.gz
Set up coverage.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dc64a63..95cb071 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,17 @@
-PYTHON=python3.3
+PYTHON=python3
+COVERAGE=coverage3
+NONTESTS=`find tulip -name [a-z]\*.py ! -name \*_test.py`
test:
$(PYTHON) runtests.py -v
+cov coverage:
+ $(COVERAGE) run runtests.py -v
+ $(COVERAGE) html $(NONTESTS)
+ $(COVERAGE) report -m $(NONTESTS)
+ echo "open file://`pwd`/htmlcov/index.html"
+
+
main:
$(PYTHON) main.py -v