summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2013-03-23 13:25:23 -0700
committerGuido van Rossum <guido@python.org>2013-03-23 13:25:23 -0700
commitd271236042b4eb088c10370a9e70cd6b3b6c85e1 (patch)
tree779416a40d6e17f1d11b5ddbaa701ef91a442075 /Makefile
parent7929e8a8c09fedeb4b25e3ffd048d3be1f879e36 (diff)
downloadtrollius-d271236042b4eb088c10370a9e70cd6b3b6c85e1.tar.gz
Fix -v flag in Makefile. Add TODO to call_repeatedly().
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 724c57c..274da4c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,17 +1,18 @@
# Some simple testing tasks (sorry, UNIX only).
PYTHON=python3
+VERBOSE=1
FLAGS=
test:
- $(PYTHON) runtests.py -v $(FLAGS)
+ $(PYTHON) runtests.py -v $(VERBOSE) $(FLAGS)
testloop:
- while sleep 1; do $(PYTHON) runtests.py -v $(FLAGS); done
+ while sleep 1; do $(PYTHON) runtests.py -v $(VERBOSE) $(FLAGS); done
# See README for coverage installation instructions.
cov coverage:
- $(PYTHON) runtests.py --coverage tulip -v $(FLAGS)
+ $(PYTHON) runtests.py --coverage tulip -v $(VERBOSE) $(FLAGS)
echo "open file://`pwd`/htmlcov/index.html"
check: