summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2013-01-10 09:57:35 -0800
committerGuido van Rossum <guido@python.org>2013-01-10 09:57:35 -0800
commitf87f5fb6e4cc1c8218e5a1ae16090263d48c4939 (patch)
tree3d5aea26e494811c618972a9666d3dbc3e625f99 /Makefile
parentc032f2a62e5d81f122bc823630552e5438757c9d (diff)
downloadtrollius-f87f5fb6e4cc1c8218e5a1ae16090263d48c4939.tar.gz
Add test id pattern matching feature to runtests.py.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 274df96..8db8ad5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,16 @@
PYTHON=python3
COVERAGE=coverage3
NONTESTS=`find tulip -name [a-z]\*.py ! -name \*_test.py`
+FLAGS=
test:
- $(PYTHON) runtests.py -v
+ $(PYTHON) runtests.py -v $(FLAGS)
testloop:
- while sleep 1; do $(PYTHON) runtests.py -v; done
+ while sleep 1; do $(PYTHON) runtests.py -v $(FLAGS); done
cov coverage:
- $(COVERAGE) run runtests.py -v
+ $(COVERAGE) run runtests.py -v $(FLAGS)
$(COVERAGE) html $(NONTESTS)
$(COVERAGE) report -m $(NONTESTS)
echo "open file://`pwd`/htmlcov/index.html"