summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-12-18 11:51:31 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-12-18 11:51:31 +0100
commitc5ccb36424cf8dea961f29226520bba6a0a807f0 (patch)
treee0beaeb4db5331852a7636f2f225a1d12bfe47f8 /setup.py
parent31147fc68aa47d529c3b97f4d93f0c62fabab29b (diff)
downloadtrollius-c5ccb36424cf8dea961f29226520bba6a0a807f0.tar.gz
setup.py: set version to 3.4.3; write the release procedure
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 13 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fcd3b6a..a5461dc 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,15 @@
+# Release procedure:
+# - run unit tests with python 3.3 in debug mode
+# - run unit tests with python dev (3.5) in debug mode
+# - maybe test examples
+# - update version in setup.py
+# - hg ci
+# - hg tag VERSION
+# - hg push
+# - python setup.py register sdist bdist_wheel upload
+# - increment version in setup.py
+# - hg ci && hg push
+
import os
try:
from setuptools import setup, Extension
@@ -15,7 +27,7 @@ if os.name == 'nt':
setup(
name="asyncio",
- version="3.4.1",
+ version="3.4.3",
description="reference implementation of PEP 3156",
long_description=open("README").read(),