summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorjacobtolar <accounts@sheckel.net>2019-10-20 20:22:55 -0500
committerGitHub <noreply@github.com>2019-10-20 20:22:55 -0500
commit399f79baff22a82f487278e44a0e10534e070b1a (patch)
tree2017a14fa2a1dc8f2a8a0a9c25b71af381e0b1ed /Makefile
parentaca2291e0586e781ea9903147f9f6709a08f48fc (diff)
downloaduwsgi-399f79baff22a82f487278e44a0e10534e070b1a.tar.gz
Add 'all', 'clean', 'check' to phony targets
The only one currently useful is 'check': since there's a directory named 'check', `make check` always just returns `make: `check' is up to date.`. But, `all` and `clean` are also phony. Actually the other rule based targets are phony too but .PHONY doesn't work with pattern rules: https://www.gnu.org/software/make/manual/make.html#Phony-Targets > The implicit rule search (see Implicit Rules) is skipped for .PHONY targets. This is why declaring a target as .PHONY is good for performance, even if you are not worried about the actual file existing.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2b05ef97..6896b424 100644
--- a/Makefile
+++ b/Makefile
@@ -19,4 +19,4 @@ tests:
%:
$(PYTHON) uwsgiconfig.py --build $@
-.PHONY: tests
+.PHONY: all clean check tests