summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPaul J Stevens <p.stevens@labdigital.nl>2018-02-08 00:09:35 +0100
committerPaul J Stevens <p.stevens@labdigital.nl>2018-02-08 00:16:13 +0100
commit8381391584da8ffd1983abdc1cd4f30c221426e9 (patch)
treed9f7f256726d732c6b10e2d9a116fb690ddb965d /Makefile
parentbd31e9e66d74960251356873248387a438a02b36 (diff)
downloaduwsgi-8381391584da8ffd1983abdc1cd4f30c221426e9.tar.gz
poc unittest using check
a simple 'works-on-my-machine' proof of concept - use the 'check' unit-test framework for C - adds build config for building static libuwsgi.a - run make tests to build the static lib, the tests, and run the tests - uses a simple make file in the check directory for now which needs better integration with the custom build system
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a4ba4e5a..fb067d2b 100644
--- a/Makefile
+++ b/Makefile
@@ -12,5 +12,11 @@ check:
plugin.%:
$(PYTHON) uwsgiconfig.py --plugin plugins/$* $(PROFILE)
+tests:
+ $(PYTHON) uwsgiconfig.py --build unittest
+ cd check && make
+
%:
$(PYTHON) uwsgiconfig.py --build $@
+
+.PHONY: tests