summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroberto@sirius <roberto@sirius>2009-12-07 11:38:28 +0100
committerroberto@sirius <roberto@sirius>2009-12-07 11:38:28 +0100
commitfbc6cec786cd3a9abbc46e77abe58f638dbf1135 (patch)
treec6e84a5a877fab52fc5c831259d2f9a02d548be1 /Makefile
parent3c07d803f5f62d557381f139647c92e2c4f69879 (diff)
downloaduwsgi-fbc6cec786cd3a9abbc46e77abe58f638dbf1135.tar.gz
new makefiles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 00000000..0cc759b4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+CC=gcc
+
+PYTHON_CFLAGS=`python-config --cflags`
+PYTHON_LIBS=`python-config --libs`
+XML_CFLAGS=`xml2-config --cflags`
+XML_LIBS=`xml2-config --libs`
+
+CFLAGS=$(PYTHON_CFLAGS) $(XML_CFLAGS)
+LD_FLAGS=$(PYTHON_LIBS) $(XML_LIBS)
+
+PROGRAM=uwsgi
+
+include base.mk