summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2018-09-05 22:56:55 -0600
committerBert JW Regeer <bertjw@regeer.org>2018-09-05 22:56:55 -0600
commit3dfe29316b5e8dcf209a2dfdcdc4632f85d48d7c (patch)
tree513de9e52cc466b42a312950f92d8066facc3461
parent49cfd93548d096e2cc7fa9860951a7acd07729d2 (diff)
downloadwaitress-3dfe29316b5e8dcf209a2dfdcdc4632f85d48d7c.tar.gz
Update waitress testing to include Python 3.7/3.8
-rw-r--r--.travis.yml11
-rw-r--r--setup.py7
-rw-r--r--tox.ini5
3 files changed, 15 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 2fc8d4c..edacbc5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -12,8 +12,14 @@ matrix:
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
- - python: nightly
+ - python: 3.7
env: TOXENV=py37
+ dist: xenial
+ sudo: true
+ - python: 3.8-dev
+ env: TOXENV=py38
+ dist: xenial
+ sudo: true
- python: pypy
env: TOXENV=pypy
- python: pypy3
@@ -23,8 +29,7 @@ matrix:
- python: 3.5
env: TOXENV=docs
allow_failures:
- - env: TOXENV=pypy3
- - env: TOXENV=py37
+ - env: TOXENV=py38
install:
- travis_retry pip install tox
diff --git a/setup.py b/setup.py
index 8c15107..318f5c3 100644
--- a/setup.py
+++ b/setup.py
@@ -55,12 +55,13 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
- "Topic :: Internet :: WWW/HTTP :: WSGI",
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
],
url='https://github.com/Pylons/waitress',
packages=find_packages(),
diff --git a/tox.ini b/tox.ini
index b9873c6..48defa3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,
+ py27,py34,py35,py36,py37,pypy,
docs,
{py2,py3}-cover,coverage
@@ -13,9 +13,10 @@ basepython =
py35: python3.5
py36: python3.6
py37: python3.7
+ py38: python3.8
pypy: pypy
py2: python2.7
- py3: python3.5
+ py3: python3.7
commands =
pip install waitress[testing]