summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-02-02 22:54:07 -0800
committerBert JW Regeer <bertjw@regeer.org>2020-04-16 22:54:29 -0700
commite2facc893269d8a7492ae23ed047fb50b71ccd6b (patch)
tree0115e17805376482a59ba06265897eb6761296af /setup.py
parent1b1dac068b7f6bd74aa0002e800e95acb0fbe3c8 (diff)
downloadwaitress-e2facc893269d8a7492ae23ed047fb50b71ccd6b.tar.gz
Move from setup.py to setup.cfg
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py80
1 files changed, 2 insertions, 78 deletions
diff --git a/setup.py b/setup.py
index 0468a82..6068493 100644
--- a/setup.py
+++ b/setup.py
@@ -1,79 +1,3 @@
-##############################################################################
-#
-# Copyright (c) 2006 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-import os
+from setuptools import setup
-from setuptools import find_packages, setup
-
-here = os.path.abspath(os.path.dirname(__file__))
-try:
- README = open(os.path.join(here, "README.rst")).read()
- CHANGES = open(os.path.join(here, "CHANGES.txt")).read()
-except IOError:
- README = CHANGES = ""
-
-docs_extras = [
- "Sphinx>=1.8.1",
- "docutils",
- "pylons-sphinx-themes>=1.0.9",
-]
-
-testing_extras = [
- "nose",
- "coverage>=5.0",
-]
-
-setup(
- name="waitress",
- version="1.4.3",
- author="Zope Foundation and Contributors",
- author_email="zope-dev@zope.org",
- maintainer="Pylons Project",
- maintainer_email="pylons-discuss@googlegroups.com",
- description="Waitress WSGI server",
- long_description=README + "\n\n" + CHANGES,
- license="ZPL 2.1",
- keywords="waitress wsgi server http",
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Environment :: Web Environment",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Zope Public License",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "Natural Language :: English",
- "Operating System :: OS Independent",
- "Topic :: Internet :: WWW/HTTP",
- "Topic :: Internet :: WWW/HTTP :: WSGI",
- ],
- url="https://github.com/Pylons/waitress",
- packages=find_packages(),
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",
- extras_require={"testing": testing_extras, "docs": docs_extras},
- include_package_data=True,
- test_suite="waitress",
- zip_safe=False,
- entry_points="""
- [paste.server_runner]
- main = waitress:serve_paste
- [console_scripts]
- waitress-serve = waitress.runner:run
- """,
-)
+setup()