summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CONTRIBUTORS.txt2
-rw-r--r--tox.ini10
2 files changed, 7 insertions, 5 deletions
diff --git a/CONTRIBUTORS.txt b/CONTRIBUTORS.txt
index f5c8c79..c3166ee 100644
--- a/CONTRIBUTORS.txt
+++ b/CONTRIBUTORS.txt
@@ -120,3 +120,5 @@ Contributors
- Jamie Matthews, 2013/06/19
- Adam Groszer, 2013/08/15
+
+- David Glick, 2015/04/13
diff --git a/tox.ini b/tox.ini
index f048ea0..df9542b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,15 +4,15 @@ envlist =
[testenv]
commands =
- python setup.py dev
- python setup.py nosetests --processes=4
+ pip install waitress[testing]
+ nosetests --processes=4
[testenv:cover]
basepython =
python2.6
commands =
- python setup.py dev
- python setup.py nosetests --with-xunit --with-xcoverage
+ pip install waitress[testing]
+ nosetests --with-xunit --with-xcoverage
deps =
nosexcover
@@ -20,7 +20,7 @@ deps =
basepython =
python2.7
commands =
- python setup.py dev
+ pip install waitress[testing]
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
deps =
Sphinx