summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2017-05-22 17:47:35 -0700
committerBert JW Regeer <bertjw@regeer.org>2017-05-22 17:47:35 -0700
commit9c66e8dd7c22da2ebdb25e5e0d4ec0b9883a6b8a (patch)
treebe4d35ed0990bebaa341031cd01a5c6f80ae6252
parent7a5c99789cc580f97decf3adf606a3de86689f74 (diff)
downloadwebob-9c66e8dd7c22da2ebdb25e5e0d4ec0b9883a6b8a.tar.gz
Move files around, make testing better
-rw-r--r--.coveragerc3
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml6
-rw-r--r--setup.py6
-rw-r--r--src/webob/__init__.py (renamed from webob/__init__.py)0
-rw-r--r--src/webob/acceptparse.py (renamed from webob/acceptparse.py)0
-rw-r--r--src/webob/byterange.py (renamed from webob/byterange.py)0
-rw-r--r--src/webob/cachecontrol.py (renamed from webob/cachecontrol.py)0
-rw-r--r--src/webob/client.py (renamed from webob/client.py)0
-rw-r--r--src/webob/compat.py (renamed from webob/compat.py)0
-rw-r--r--src/webob/cookies.py (renamed from webob/cookies.py)0
-rw-r--r--src/webob/datetime_utils.py (renamed from webob/datetime_utils.py)0
-rw-r--r--src/webob/dec.py (renamed from webob/dec.py)0
-rw-r--r--src/webob/descriptors.py (renamed from webob/descriptors.py)0
-rw-r--r--src/webob/etag.py (renamed from webob/etag.py)0
-rw-r--r--src/webob/exc.py (renamed from webob/exc.py)0
-rw-r--r--src/webob/headers.py (renamed from webob/headers.py)0
-rw-r--r--src/webob/multidict.py (renamed from webob/multidict.py)0
-rw-r--r--src/webob/request.py (renamed from webob/request.py)0
-rw-r--r--src/webob/response.py (renamed from webob/response.py)0
-rw-r--r--src/webob/static.py (renamed from webob/static.py)0
-rw-r--r--src/webob/util.py (renamed from webob/util.py)0
-rw-r--r--tox.ini32
23 files changed, 22 insertions, 26 deletions
diff --git a/.coveragerc b/.coveragerc
index 847d0a0..e4b6520 100644
--- a/.coveragerc
+++ b/.coveragerc
@@ -1,8 +1,7 @@
[run]
parallel = true
source =
- src/webob
- tests
+ webob
omit =
[paths]
diff --git a/.gitignore b/.gitignore
index 83acee6..37e07e6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -11,6 +11,7 @@ build/
dist/
env*/
.coverage
+.coverage.*
.cache/
WebOb.egg-info/
pytest*.xml
diff --git a/.travis.yml b/.travis.yml
index 895d219..2cfea21 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,12 +14,14 @@ matrix:
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
+ - python: 3.6
+ env: TOXENV=docs
- python: nightly
env: TOXENV=py37
- python: pypy
env: TOXENV=pypy
- - python: 3.5
- env: TOXENV=py2-cover,py3-cover,coverage
+ - python: 3.6
+ env: TOXENV=py27,py36,coverage
allow_failures:
- env: TOXENV=py37
diff --git a/setup.py b/setup.py
index d74f25e..5729613 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
import os
-from setuptools import setup
+from setuptools import setup, find_packages
here = os.path.abspath(os.path.dirname(__file__))
try:
@@ -48,7 +48,9 @@ setup(
maintainer='Pylons Project',
url='http://webob.org/',
license='MIT',
- packages=['webob'],
+ packages=find_packages('src', exclude=['tests']),
+ package_dir={'': 'src'},
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*',
zip_safe=True,
extras_require={
'testing': testing_extras,
diff --git a/webob/__init__.py b/src/webob/__init__.py
index 7713212..7713212 100644
--- a/webob/__init__.py
+++ b/src/webob/__init__.py
diff --git a/webob/acceptparse.py b/src/webob/acceptparse.py
index 6d47e37..6d47e37 100644
--- a/webob/acceptparse.py
+++ b/src/webob/acceptparse.py
diff --git a/webob/byterange.py b/src/webob/byterange.py
index d1b8a6d..d1b8a6d 100644
--- a/webob/byterange.py
+++ b/src/webob/byterange.py
diff --git a/webob/cachecontrol.py b/src/webob/cachecontrol.py
index 9176ec9..9176ec9 100644
--- a/webob/cachecontrol.py
+++ b/src/webob/cachecontrol.py
diff --git a/webob/client.py b/src/webob/client.py
index 339e4c0..339e4c0 100644
--- a/webob/client.py
+++ b/src/webob/client.py
diff --git a/webob/compat.py b/src/webob/compat.py
index 049fdab..049fdab 100644
--- a/webob/compat.py
+++ b/src/webob/compat.py
diff --git a/webob/cookies.py b/src/webob/cookies.py
index 5dee971..5dee971 100644
--- a/webob/cookies.py
+++ b/src/webob/cookies.py
diff --git a/webob/datetime_utils.py b/src/webob/datetime_utils.py
index 5975c8d..5975c8d 100644
--- a/webob/datetime_utils.py
+++ b/src/webob/datetime_utils.py
diff --git a/webob/dec.py b/src/webob/dec.py
index efdd9a8..efdd9a8 100644
--- a/webob/dec.py
+++ b/src/webob/dec.py
diff --git a/webob/descriptors.py b/src/webob/descriptors.py
index 4e6b7f5..4e6b7f5 100644
--- a/webob/descriptors.py
+++ b/src/webob/descriptors.py
diff --git a/webob/etag.py b/src/webob/etag.py
index 66df56e..66df56e 100644
--- a/webob/etag.py
+++ b/src/webob/etag.py
diff --git a/webob/exc.py b/src/webob/exc.py
index deffc64..deffc64 100644
--- a/webob/exc.py
+++ b/src/webob/exc.py
diff --git a/webob/headers.py b/src/webob/headers.py
index 55385c8..55385c8 100644
--- a/webob/headers.py
+++ b/src/webob/headers.py
diff --git a/webob/multidict.py b/src/webob/multidict.py
index 795a296..795a296 100644
--- a/webob/multidict.py
+++ b/src/webob/multidict.py
diff --git a/webob/request.py b/src/webob/request.py
index 923cce5..923cce5 100644
--- a/webob/request.py
+++ b/src/webob/request.py
diff --git a/webob/response.py b/src/webob/response.py
index ceaae27..ceaae27 100644
--- a/webob/response.py
+++ b/src/webob/response.py
diff --git a/webob/static.py b/src/webob/static.py
index 35881d3..35881d3 100644
--- a/webob/static.py
+++ b/src/webob/static.py
diff --git a/webob/util.py b/src/webob/util.py
index b7db88c..b7db88c 100644
--- a/webob/util.py
+++ b/src/webob/util.py
diff --git a/tox.ini b/tox.ini
index 79ee9c3..1e33114 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
py27,py33,py34,py35,py36,py37,pypy,
- docs,{py2,py3}-cover,coverage
+ docs,coverage,pep8
skip_missing_interpreters = True
[testenv]
@@ -20,29 +20,14 @@ basepython =
commands =
pip install webob[testing]
- py.test tests --junitxml=pytest-{envname}.xml {posargs:}
+ py.test tests --junitxml=pytest-{envname}.xml --cov --cov-report=term-missing {posargs:}
-[py-cover]
-commands =
- pip install webob[testing]
- py.test tests --cov-report term-missing --cov=webob
-
-[testenv:py2-cover]
-commands =
- {[py-cover]commands}
-setenv =
- COVERAGE_FILE=.coverage.py2
-
-[testenv:py3-cover]
-commands =
- {[py-cover]commands}
setenv =
- COVERAGE_FILE=.coverage.py3
+ COVERAGE_FILE=.coverage.{envname}
[testenv:coverage]
-basepython = python3.5
+basepython = python3.6
commands =
- coverage erase
coverage combine
coverage xml
coverage report --show-missing --fail-under=100
@@ -52,9 +37,16 @@ setenv =
COVERAGE_FILE=.coverage
[testenv:docs]
-basepython = python3.5
+basepython = python3.6
whitelist_externals = make
commands =
pip install webob[docs]
make -C docs html epub BUILDDIR={envdir} "SPHINXOPTS=-W -E"
+[testenv:pep8]
+basepython = python3.6
+commands =
+ flake8 src/webob/
+deps =
+ flake8
+