summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <github@martintribe.org>2013-03-12 13:46:45 -0500
committerJoel Martin <github@martintribe.org>2013-03-12 13:46:45 -0500
commitdb6a7e3e28cd4631d4db8a9ac240a0041d938d60 (patch)
treebfea3e0633c9db8571e02ed345535de18b4c4373
parentd9aedfe7d3453e358b28c2feceb3bfa52895d404 (diff)
downloadwebsockify-0.4.1.tar.gz
Update to version 0.4.1v0.4.1
*** IMPORTANT NOTE *** 0.4.X is the last minor version to support the Hixie protocol. 0.5.0 will drop the Hixie protocol support. The latest released version of all major browsers (and web-socket-js) support the IETF 6455 protocol. - Other changes: add 'include/' sub-dir to source distribution and to installed packaged.
-rw-r--r--CHANGES.txt7
-rw-r--r--MANIFEST.in2
-rw-r--r--README.md17
-rw-r--r--setup.py10
4 files changed, 26 insertions, 10 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index b5b8dbd..e2b971c 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,13 @@
Changes
=======
+0.4.1 - Mar 12, 2013
+--------------------
+
+ * ***NOTE*** : 0.5.0 will drop Hixie protocol support
+ * add include/ directory and remove some dev files from source
+ distribution.
+
0.4.0 - Mar 12, 2013
--------------------
diff --git a/MANIFEST.in b/MANIFEST.in
index 2dd46d2..27bf0d3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1 +1 @@
-include CHANGES.txt *.py README.md LICENSE.txt
+include CHANGES.txt websockify include README.md LICENSE.txt
diff --git a/README.md b/README.md
index 2cfac0f..1e91910 100644
--- a/README.md
+++ b/README.md
@@ -10,14 +10,15 @@ the target in both directions.
### WebSockets binary data
-Websockify supports all versions of the WebSockets protocol (Hixie and
-HyBi). The older Hixie versions of the protocol only support UTF-8
-text payloads. In order to transport binary data over UTF-8 an
-encoding must used to encapsulate the data within UTF-8.
-
-With Hixie clients, Websockify uses base64 to encode all traffic to
-and from the client. This does not affect the data between websockify
-and the server.
+Websockify 0.4.X supports all versions of the WebSockets protocol
+(Hixie and HyBi). Starting with websockify 0.5.0, only the HyBi / IETF
+6455 WebSocket protocol is supported.
+
+The older Hixie versions of the protocol only support UTF-8 text
+payloads. In order to transport binary data over UTF-8 an encoding
+must used to encapsulate the data within UTF-8. With Hixie clients,
+Websockify uses base64 to encode all traffic to and from the client.
+This does not affect the data between websockify and the server.
With HyBi clients, websockify negotiates whether to base64 encode
traffic to and from the client via the subprotocol header
diff --git a/setup.py b/setup.py
index 5794bda..e53a715 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.4.0'
+version = '0.4.1'
name = 'websockify'
long_description = open("README.md").read() + "\n" + \
open("CHANGES.txt").read() + "\n"
@@ -12,6 +12,14 @@ setup(name=name,
classifiers=[
"Programming Language :: Python",
],
+ data_files=[('share/websockify/include',
+ ['include/util.js',
+ 'include/base64.js',
+ 'include/websock.js']),
+ ('share/websockify/include/web-socket-js',
+ ['include/web-socket-js/WebSocketMain.swf',
+ 'include/web-socket-js/swfobject.js',
+ 'include/web-socket-js/web_socket.js'])],
keywords='noVNC websockify',
license='LGPLv3',
url="https://github.com/kanaka/websockify",