summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt11
-rw-r--r--other/js/package.json2
-rw-r--r--setup.py2
3 files changed, 13 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 51feefa..10f1ca8 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,17 @@
Changes
=======
+0.8.0
+-----
+
+* Make websockify properly terminate children on SIGTERM (#226)
+* Remove logging in signal handlers (this can cause Python to hang under certain conditions) (#219)
+* Make it easier to log to a file (#205)
+* Add support for IPv6 addresses in tokens in the TokenFile token plugins (#197)
+* Improve auth plugin framework to enable better support for HTTP auth (#194, #201)
+* Fix bug in JSONTokenAPI token plugin (#192)
+* Fix a missing variable in the exception handler (#178)
+
0.7.0
-----
diff --git a/other/js/package.json b/other/js/package.json
index 3bb4ad5..cf84539 100644
--- a/other/js/package.json
+++ b/other/js/package.json
@@ -3,7 +3,7 @@
"name": "websockify",
"description": "websockify is a WebSocket-to-TCP proxy/bridge",
"license": "LGPL-3.0",
- "version": "0.7.1",
+ "version": "0.8.0",
"repository": {
"type": "git",
"url": "git://github.com/kanaka/websockify.git"
diff --git a/setup.py b/setup.py
index 0ba28c8..4fa5926 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.7.0'
+version = '0.8.0'
name = 'websockify'
long_description = open("README.md").read() + "\n" + \
open("CHANGES.txt").read() + "\n"