summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt9
-rw-r--r--wheel/__init__.py2
2 files changed, 10 insertions, 1 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 032e70f..34dd66c 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,12 @@
+0.21.0
+======
+- Pregenerated scripts are the default again.
+- "setup.py bdist_wheel --skip-scripts" turns them off.
+- setuptools is no longer a listed requirement for the 'wheel'
+ package. It is of course still required in order for bdist_wheel
+ to work.
+- "python -m wheel" avoids importing pkg_resources until it's necessary.
+
0.20.0
======
- No longer include console_scripts in wheels. Ordinary scripts (shell files,
diff --git a/wheel/__init__.py b/wheel/__init__.py
index 8607d4e..fe5b1d8 100644
--- a/wheel/__init__.py
+++ b/wheel/__init__.py
@@ -1,2 +1,2 @@
# __variables__ with double-quoted values will be available in setup.py:
-__version__ = "0.20.0"
+__version__ = "0.21.0"