summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 15 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index bd1c900..cde619a 100644
--- a/setup.py
+++ b/setup.py
@@ -15,17 +15,21 @@ setup(name='wheel',
description='A built-package format for Python.',
long_description=README + '\n\n' + CHANGES,
classifiers=[
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
- ],
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ ],
author='Daniel Holth',
author_email='dholth@fastmail.fm',
url='https://bitbucket.org/pypa/wheel/',
@@ -38,10 +42,8 @@ setup(name='wheel',
'wheel.signatures'
],
extras_require={
- ':python_version=="2.6"': ['argparse'],
'signatures': ['keyring', 'keyrings.alt'],
'signatures:sys_platform!="win32"': ['pyxdg'],
- 'signatures:python_version=="2.6"': ['importlib'],
'faster-signatures': ['ed25519ll'],
'tool': []
},
@@ -57,4 +59,3 @@ setup(name='wheel',
]
}
)
-