summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authoroliver <oliver@thelettero.co.uk>2009-05-23 12:44:02 +0200
committeroliver <oliver@thelettero.co.uk>2009-05-23 12:44:02 +0200
commit621c08a2a63e1f4b322aa1b29f3e9d6b6673b6c5 (patch)
tree68d42f82543170bed3d899761a5a3114e3acb320 /setup.py
parentbb3e439e980be9ee06dca85aac9a724d84a039ab (diff)
downloadyoyo-621c08a2a63e1f4b322aa1b29f3e9d6b6673b6c5.tar.gz
Rename to yoyo-migrate, remove storm dependency and improve reliability and featureset
Ignore-this: d37f291d92f6cf01d9c3cc18c0b1827e
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 21 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 873c381..232d8f5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,25 +1,39 @@
#!/usr/bin/env python
+import os
try:
from setuptools import setup
except ImportError:
from distutils.core import setup
+def readfile(path):
+ f = open(path, 'r')
+ try:
+ return f.read()
+ finally:
+ f.close()
-from distutils.core import setup
setup(
- name='torque-migrations',
- description='Storm backed database migration script',
+ name='yoyo.migrate',
+ description='Database migrations tool, using SQL and DB-API',
+ long_description=readfile(
+ os.path.join(os.path.dirname(__file__), 'README')
+ ).decode('utf-8').encode('ascii', 'replace'),
+
author='Oliver Cope',
- author_email='oliver@thelettero.co.uk',
- url='http://www.thelettero.co.uk/products/',
- scripts=['torque-migrations'],
+ author_email='oliver@redgecko.org',
+ scripts=['yoyo-migrate'],
install_requires=[
- u'Storm',
],
+ extras_require = {
+ 'mysql': [u'mysql-python'],
+ 'postgres': [u'psycopg2'],
+ },
dependency_links=[
'http://sourceforge.net/project/showfiles.php?group_id=22307'
],
+ namespace_packages=['yoyo'],
+ packages=['yoyo.migrate'],
)