summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jason+github@nextthought.com>2018-09-22 08:19:11 -0500
committerGitHub <noreply@github.com>2018-09-22 08:19:11 -0500
commit0ea91989e33592155891da0eeace996b0e4d3506 (patch)
tree0ac125ae24fa73672d79d38adf0a975179e82438
parent4a4c1a045f409c35ad9407ecb3aa7e53c42197ca (diff)
parent7cc30bd35d88425b4611d10bddbe6911a16b766e (diff)
downloadzope-configuration-0ea91989e33592155891da0eeace996b0e4d3506.tar.gz
Merge pull request #23 from zopefoundation/issue20
Add support for Python 3.7; drop Python 3.3
-rw-r--r--.travis.yml9
-rw-r--r--CHANGES.rst8
-rw-r--r--setup.py43
-rw-r--r--tox.ini5
4 files changed, 19 insertions, 46 deletions
diff --git a/.travis.yml b/.travis.yml
index ddcc8dc..05ad82f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,11 +2,16 @@ language: python
sudo: false
python:
- 2.7
- - 3.3
- 3.4
- 3.5
- 3.6
- - pypy-5.4.1
+ - pypy
+ - pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
script:
- coverage run -m zope.testrunner --test-path=src --auto-color --auto-progress
diff --git a/CHANGES.rst b/CHANGES.rst
index 4f07c76..3002236 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,9 +1,15 @@
Changes
=======
-4.1.1 (unreleased)
+4.2.0 (unreleased)
------------------
+- Add support for Python 3.7.
+
+- Drop support for Python 3.3.
+
+- Drop support for ``python setup.py test``.
+
- Fix resolving names from a Python 2 package whose `__init__.py` has
unicode elements in `__all__`.
diff --git a/setup.py b/setup.py
index 91a5d8a..fe4d906 100644
--- a/setup.py
+++ b/setup.py
@@ -24,39 +24,6 @@ def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
-def _modname(path, base, name=''):
- if path == base:
- return name
- dirname, basename = os.path.split(path)
- return _modname(dirname, base, basename + '.' + name)
-
-def alltests():
- import logging
- import pkg_resources
- import unittest
-
- class NullHandler(logging.Handler):
- level = 50
-
- def emit(self, record):
- pass
-
- logging.getLogger().addHandler(NullHandler())
-
- suite = unittest.TestSuite()
- base = pkg_resources.working_set.find(
- pkg_resources.Requirement.parse('zope.configuration')).location
- for dirpath, dirnames, filenames in os.walk(base):
- if os.path.basename(dirpath) == 'tests':
- for filename in filenames:
- if ( filename.endswith('.py') and
- filename.startswith('test') ):
- mod = __import__(
- _modname(dirpath, base, os.path.splitext(filename)[0]),
- {}, {}, ['*'])
- suite.addTest(mod.test_suite())
- return suite
-
TESTS_REQUIRE = [
'zope.testrunner',
]
@@ -70,7 +37,7 @@ setup(name='zope.configuration',
read('README.rst')
+ '\n\n' +
read('CHANGES.rst')
- ),
+ ),
keywords="zope configuration zcml",
classifiers=[
'Development Status :: 5 - Production/Stable',
@@ -81,10 +48,10 @@ setup(name='zope.configuration',
"Programming Language :: Python :: 2",
'Programming Language :: Python :: 2.7',
"Programming Language :: Python :: 3",
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -97,9 +64,8 @@ setup(name='zope.configuration',
package_dir={'': 'src'},
namespace_packages=['zope'],
extras_require={
- 'docs': ['Sphinx', 'repoze.sphinx.autointerface'],
- 'test': TESTS_REQUIRE,
- 'testing': TESTS_REQUIRE + ['nose', 'coverage'],
+ 'docs': ['Sphinx', 'repoze.sphinx.autointerface'],
+ 'test': TESTS_REQUIRE,
},
install_requires=[
'setuptools',
@@ -110,5 +76,4 @@ setup(name='zope.configuration',
include_package_data=True,
zip_safe=False,
tests_require=TESTS_REQUIRE,
- test_suite='__main__.alltests',
)
diff --git a/tox.ini b/tox.ini
index 7ce21b5..47f7ed1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,6 @@
[tox]
envlist =
-# Jython support pending 2.7 support, due 2012-07-15 or so. See:
-# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py27,py33,py34,py35,jython,pypy,coverage,docs
- py27,py33,py34,py35,py36,pypy,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
deps =