summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-09-17 11:47:14 -0500
committerJason Madden <jamadden@gmail.com>2020-09-17 11:47:14 -0500
commita434eb90cb5d1f7a0f33a70f91de432183f48bfa (patch)
tree7d9778fed0e97f6da9d94a2bd85a034abf04034c
parentf50e83f424da23d5f58a808b0b3c0b837b24eba9 (diff)
downloadzope-event-py38.tar.gz
Add support for Python 3.8/3.9 and drop support for 3.4py38
-rw-r--r--.travis.yml11
-rw-r--r--CHANGES.rst8
-rw-r--r--setup.py7
-rw-r--r--tox.ini2
4 files changed, 14 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index b7d83f0..5ae61c1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,17 +1,14 @@
language: python
-sudo: false
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
+ - 3.8
+ - 3.9-dev
- pypy
- pypy3
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
+
script:
- coverage run -m zope.testrunner --test-path=src
diff --git a/CHANGES.rst b/CHANGES.rst
index 0fc6951..02d244a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,12 @@
``zope.event`` Changelog
==========================
-4.5 (unreleased)
-================
+4.5.0 (unreleased)
+==================
+
+- Add support for Python 3.8 and 3.9.
-- Nothing changed yet.
+- Remove support for Python 3.4.
4.4 (2018-10-05)
diff --git a/setup.py b/setup.py
index d91ce80..e52a8d0 100644
--- a/setup.py
+++ b/setup.py
@@ -28,8 +28,8 @@ def read(*rnames):
setup(
name='zope.event',
- version='4.5.dev0',
- url='http://github.com/zopefoundation/zope.event',
+ version='4.5.0.dev0',
+ url='https://github.com/zopefoundation/zope.event',
license='ZPL 2.1',
description='Very basic event publishing system',
author='Zope Foundation and Contributors',
@@ -49,10 +49,11 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: Jython",
"Programming Language :: Python :: Implementation :: PyPy",
diff --git a/tox.ini b/tox.ini
index a118c23..30eebff 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@ envlist =
# requests -> html5 libraries. See
# https://github.com/html5lib/html5lib-python/pull/150
# py27,py33,py34,pypy,pypy3,jython,coverage,docs
- py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
+ py27,py35,py36,py37,py38,py39,pypy,pypy3,coverage,docs
[testenv]
commands =